February 10, 2020

Can I install the app on my Mac with OS X El Capitan?

I can't find any information on what versions of macOS are supported - can I use the app on El Capitan?   

Answer:

Currently PDF Expert for Mac is fully compatible with macOS (OS X) 10.12 or later, so you won't be able to install the app on your Mac computer with OS X El Capitan.



Was this article helpful?YesNo

Thanks for your feedback! 😊

Sorry about that! How can we make it better?

The website is currently on the reconstruction. After the completion of all works the website will be opened.

We apologize for any inconvenience.