October 11, 2017

Which PDF Expert for Mac version is compatible with MacOS 10.8.5?

When I tried to open the program, it said it would not work with the version of macOS that I have.

Answer:

We don't have an older version of PDF Expert for Mac as the app is relatively new. Our app's requirements regarding OS X version is OS X 10.12 or later. If possible, we recommend you to upgrade your macOS version before using PDF Expert for Mac.

Was this article helpful?YesNo

Thanks for your feedback! 😊

Sorry about that! How can we make it better?

The website is currently on the reconstruction. After the completion of all works the website will be opened.

We apologize for any inconvenience.